Zero-day vulnerability in Microsoft Exchange Server

Input validation error
CVE-2021-42321

Vulnerability details

Advisory: SB2021110928 - Remote code execution in Microsoft Exchange Server

Vulnerable component: Microsoft Exchange Server

CVE-ID: CVE-2021-42321

CVSSv3 score: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H/E:H/RL:O/RC:C

CWE-ID: CWE-20 - Improper Input Validation

Description:

The vulnerability allows a remote user to compromise the affected system.

The vulnerability exists due to insufficient validation of cmdlet arguments. A remote user can run a specially crafted cmdlet and execute arbitrary commands on the system.

Note, the vulnerability is being actively exploited in the wild.

External links:

https://msrc.microsoft.com/update-guide/en-US/vulnerability/CVE-2021-42321