Zero-day vulnerability in WD My Book Live Duo

Improper access control
CVE-2021-35941

Not patched


Vulnerability details

Advisory: SB2021063021 - Improper access control in WD My Book Live and WD My Book Live Duo

Vulnerable component: WD My Book Live Duo

CVE-ID: CVE-2021-35941

CVSSv3 score: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N/E:H/RL:U/RC:C

CWE-ID: CWE-284 - Improper Access Control

Description:

The vulnerability allows a remote attacker to delete all data on the system.

The vulnerability exists due to improper access restrictions to the administrator API. A remote non-authenticated attacker can send a specially crafted HTTP request to the exposed API and perform a system factory restore, deleting all data on the NAS device.

Note, the vulnerability is being actively exploited in the wild along with vulnerability #VU15460.

External links:

https://www.westerndigital.com/support/productsecurity/wdc-21008-recommended-security-measures-wd-mybooklive-wd-mybookliveduo