Zero-day vulnerability in Adobe Acrobat Reader

Heap-based buffer overflow
CVE-2021-21017

Vulnerability details

Advisory: SB2021021001 - Multiple vulnerabilities in Adobe Reader and Acrobat

Vulnerable component: Adobe Acrobat Reader

CVE-ID: CVE-2021-21017

CVSSv3 score: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H/E:H/RL:O/RC:C

CWE-ID: CWE-122 - Heap-based Buffer Overflow

Description:

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error when processing PDF files. A remote attacker can create a specially crafted PDf file, trick the victim into opening it, trigger a heap-based buffer overflow and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Note, the vulnerability is being actively exploited in the wild.

External links:

https://helpx.adobe.com/security/products/acrobat/apsb21-09.html