Zero-day vulnerability in Oracle Solaris

Improper input validation
CVE-2020-14871

According to FireEye, the vulnerability is being exploited in the wild by the actor tracked as UNC1945.

Vulnerability details

Advisory: SB2020102303 - Multiple vulnerabilities in Oracle Solaris

Vulnerable component: Oracle Solaris

CVE-ID: CVE-2020-14871

CVSSv3 score: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H/E:H/RL:O/RC:C

CWE-ID: CWE-20 - Improper Input Validation

Description:

The vulnerability allows a remote non-authenticated attacker to execute arbitrary code.

The vulnerability exists due to improper input validation within the Pluggable authentication module (PAM) component in Oracle Solaris. A remote non-authenticated attacker can exploit this vulnerability to execute arbitrary code.

Note, this vulnerability is being actively exploited in the wild.